BBB Sponsor

Bass Tackle at Guaranteed Lowest Prices

BBB Sponsors

Authorized AMSOIL Dealer

Your best choice for the Primary Tackle you need!

Fishing Tackle With Guaranteed Best Price!

Garmin Marine Electronics

* Who's Online

  • Dot Guests: 25
  • Dot Hidden: 0
  • Dot Users: 0

There aren't any users online.

Author Topic: 859 won't power up  (Read 1629 times)

Offline frugalangler

  • Smallmouth Bass
  • ****
  • Posts: 356
  • Thanks: 1
  • Play hard, Fish harder!!!!!
  • Referrals: 0
    • Club website
859 won't power up
« on: April 24, 2017, 10:37:52 AM »
Friend's 859 had some electrical connection issues - loose connection on neg power wire - would power up but shut off after period of time, tightened connections and now unit shows power (illumination of power button) but will not power up. We've disconnected from power and let set overnight, still won't power up.

Humminbird wants $400 sent in to diagnose, no help on phone to diagnose. Does anyone know if there is a 'hard reset' procedure similar to Lowrance's multi-button sequence that will do a power on reset?

$400 is nearly what the unit is worth used, hate to spend that kind of coin on an older unit if it can be reset. It worked fine w/ the loose connection until the boat vibration caused it to break and power off.
FrugalAngler
Ranger198VX/Yamaha VMax
Jeep Grand Cherokee EcoDiesel

Offline Curt

  • BBB Admin
  • Administrator
  • Largemouth Bass
  • *****
  • Posts: 5699
  • Thanks: 10
  • Fish On!
  • Referrals: 264
    • CurtSnow.com
  • My Biggest Bass: LMB - 9 lbs. 2 oz. (RI) 9 lbs. 14 oz. (California Delta) - SMB 5 lbs. 10 oz. (CT)
Re: 859 won't power up
« Reply #1 on: April 24, 2017, 11:13:54 AM »
I don't think there is a hard reset function on those units. And even if there was, you would need to get it to power on to do so, since hard resets usually involve either holding a button for a long period of time while it powers on, or a combination of buttons after it has powered on.

I have a 788 that I have had problems with powering down or the screen turning gray or black, but it ended up being a defective screen. When the screen got warm, it would do this. Since it was out of warranty by the time I figured out what it was (I originally thought it was a power issues), I now just run it with the screen set to about 80% brightness instead of 100%.

But I'm going to replace this unit soon with a used one that I picked up over the winter anyway. Oops.. I digressed  (fp)

Professionally Designed Websites Starting at Just $99 http://www.ProWebsitesUnlimited.com

Tags:
 

* Recent Posts

Custom Crankbait Review by Curt
[September 18, 2020, 01:30:40 PM]


Re: Added This To The Talon by Curt
[September 02, 2020, 04:06:05 PM]


Re: Added This To The Talon by Jig Man
[August 29, 2020, 04:23:12 PM]


Added This To The Talon by Curt
[August 27, 2020, 03:33:59 PM]


Re: New Addition to the G3! by Jig Man
[August 24, 2020, 10:30:36 AM]


Re: New Addition to the G3! by Curt
[August 23, 2020, 01:31:25 PM]


Re: New Addition to the G3! by Curt
[August 17, 2020, 08:24:37 AM]


Re: New Addition to the G3! by Nightmare
[August 17, 2020, 01:36:40 AM]

* Forum Staff

Curt admin Curt
Administrator
admin Jive
Administrator
Mitz gmod Mitz
Global Moderator